Forum

You are not logged in.

#1 06-11-2010 14:00:39

sragons
Membre
Registered: 06-11-2010
Posts: 2

lxml

Bonjour,
Je voudrais faire de la transformation xsl de fichiers xml
sous Django. Malheureusement la librairie lxml n'est pas disponible.

Est-il possible d'envisager son installation sur alwaydata ?
Comme c'est une librairie non entièrement basé sur du python,
elle est rarement présente chez les hébergeurs même si c'est
un programme tres recherché.

Cordialement
Sébastien

Offline

#2 06-11-2010 14:27:44

@Cyril
Staff
From: Paris
Registered: 06-02-2007
Posts: 5,579
Website

Re: lxml

Bonjour,

lxml sera rajouté à notre prochaine fournée de bibliothèques Python (qui devrait arriver en théorie ce mois-ci). En attendant, vous pouvez l'ajouter vous-même à votre compte en suivant notre documentation.

Offline

#3 06-11-2010 14:42:55

sragons
Membre
Registered: 06-11-2010
Posts: 2

Re: lxml

Merci !
alwaysdata c'est épatent
Sébastien

Offline

#4 23-11-2011 14:01:52

dimgunner
Membre
Registered: 23-11-2011
Posts: 2

Re: lxml

Cyril wrote:

Bonjour,

lxml sera rajouté à notre prochaine fournée de bibliothèques Python (qui devrait arriver en théorie ce mois-ci). En attendant, vous pouvez l'ajouter vous-même à votre compte en suivant notre documentation.

Whether lxml library has been already added to Alwaysdata Python libraries package?

Offline

#5 23-11-2011 14:21:16

@Cyril
Staff
From: Paris
Registered: 06-02-2007
Posts: 5,579
Website

Re: lxml

Not yet, but you can install it yourself in your own account.

Offline

#6 21-10-2015 12:33:22

dimgunner
Membre
Registered: 23-11-2011
Posts: 2

Re: lxml

Unfortunately, the problem is that the lxml requires libxml2 version 2.7.0 minimum

I tried to perform this command:

pip install -U --install-option="--prefix=$HOME/.local" lxml

and received error in ./pip-log.txt:

In file included from src/lxml/lxml.etree.c:323:
src/lxml/includes/etree_defs.h:19:4: error: #error minimum required version of libxml2 is 2.7.0

Offline

#7 07-02-2016 01:09:44

marc
Membre
From: Lille
Registered: 07-03-2010
Posts: 14
Website

Re: lxml

Bonjour à tous,

J'ai également le même soucis, impossible d'installer lxml, le problème est ouvert depuis 2010, merci de faire quelque chose.

Bien cordialement.


Scrum Master

Offline

#8 15-04-2016 23:18:56

Draky
Membre
From: France - Manche
Registered: 15-10-2011
Posts: 86
Website

Re: lxml

Bonjour.

Je rajoute une demande pour une mise à jour de libxml2 car owncloud 9 demande la version é.7.0 ou + mais actuellement c'est la version 2.6.32 qui est installé donc... pas de owncloud.

Je fais aussi une demande par support.

Merci.


Parigot-Manchot
---------------
Hébergé chez AlwaysData, what else ?

Offline

Board footer

Powered by FluxBB