Forum

You are not logged in.

#1 05-10-2017 20:43:20

oliv
Membre
Registered: 31-05-2013
Posts: 25

Erreur openssl sur l'envoi de mail

Bonjour,

Mon site web envoi des rappels pour plusieurs personnes et je remarque que l'envoi de mail échoue lorsqu'il essaye d'envoyer plus de 12 rappels. Un rappel est une pour une personne dédiée.

J'ai une erreur

OpenSSL::SSL::SSLError: SSL_read:: shutdown while in init                                                                                           
        from /usr/alwaysdata/ruby/1.9.2-p320/lib/ruby/1.9.1/openssl/buffering.rb:145:in `sysread_nonblock'                                          
        from /usr/alwaysdata/ruby/1.9.2-p320/lib/ruby/1.9.1/openssl/buffering.rb:145:in `read_nonblock'                                             
        from /usr/alwaysdata/ruby/1.9.2-p320/lib/ruby/1.9.1/net/protocol.rb:135:in `rbuf_fill' 

Je tourne sur un site ruby on rails, je reproduis l'erreur aléatoirement quand j'essaye d'envoyer 13 rappels, parfois les 13 passent et parfois j'en fais que 11, et ça arrive que parfois j'échoue sur le premier.

Avez-vous une idée ?

Offline

#2 09-10-2017 08:43:32

oliv
Membre
Registered: 31-05-2013
Posts: 25

Re: Erreur openssl sur l'envoi de mail

Finalement j'ai trouvé en désactivant le paramètre : enable_starttls_auto

```
:address => "smtp-clicarbitre.alwaysdata.net",
:port => "25",
:authentication => 'plain',
:enable_starttls_auto => false,
:openssl_verify_mode => 'none'

Offline

Board footer

Powered by FluxBB