Forum

Need some help? Ask our community for its assistance!

You are not logged in.

#1 06-09-2007 11:13:08

yml
Membre
Registered: 28-08-2007
Posts: 124

SMTP : (111, 'Connection refused')

Bonjour,
Avez vous fait des modifications sur la configuration de vos serveurs SMTP ou de vos firewalls?
Car le problème que je croyais résolu en fin de semaine dernière est revenu. Je mon application django ne peux plus se connecter à votre serveur SMTP.

Voici le message d'erreur:

error at /accounts/register/
(111, 'Connection refused')
Request Method:     POST
Request URL:     http://yml.alwaysdata.net/accounts/register/
Exception Type:     error
Exception Value:     (111, 'Connection refused')
Exception Location:     /home/yml/www/external_libs/django/core/mail.py in open, line 128
Python Executable:     /usr/bin/python
Python Version:     2.4.4

Je n'ai pas fais de modification dans ma configuration :

##--Configuration for Alwaysdata.com -- OK--                                    
EMAIL_HOST = 'smtp.alwaysdata.com'                                              
DEFAULT_FROM_EMAIL = 'yml@alwaysdata.net'

Par contre j'ai externalisé la configuration des serveur dans un fichier "settings_private.py" qui est importé à la fin de mon fichier settings.py, avec la commande suivante: from settings_private import *

Le problème est reproductible à l'adresse suivante: http://yml.alwaysdata.net/accounts/register/

Cordialement,

--yml

Offline

#2 06-09-2007 11:18:33

@Cyril
Staff
From: Paris
Registered: 06-02-2007
Posts: 5,654
Website

Re: SMTP : (111, 'Connection refused')

Rien n'a été modifié de notre côté.

Je ne sais pas si l'import à partir de settings.py est valide en Python. Pouvez-vous réessayer en remettant les valeurs directement dans settings.py ? Je soupçonne que l'import ne marche pas, du coup EMAIL_HOST ne serait pas défini, et je parie que la valeur par défaut est localhost (d'où le Connection refused).

Offline

#3 06-09-2007 11:45:57

yml
Membre
Registered: 28-08-2007
Posts: 124

Re: SMTP : (111, 'Connection refused')

Cyril,
EMAIL_HOST est correctement defini si j'en crois la page d'erreur django.

DEFAULT_FROM_EMAIL      
u'yml@alwaysdata.net'
DISALLOWED_USER_AGENTS     
()
EMAIL_HOST     
u'smtp.alwaysdata.com'
EMAIL_HOST_PASSWORD     
u'********************'
EMAIL_HOST_USER     
u''
EMAIL_PORT     
8025
EMAIL_SUBJECT_PREFIX     
u'[Django] '
EMAIL_USE_TLS     
False

Je vais remettre la configuration SMTP dans le fichier settings.py cependant je ne pense pas que cela soit la source du problème car la configuration db ce trouve dans le même fichier.
Merci
--yml

Offline

#4 06-09-2007 11:48:18

@Cyril
Staff
From: Paris
Registered: 06-02-2007
Posts: 5,654
Website

Re: SMTP : (111, 'Connection refused')

Euh, c'est quoi ce EMAIL_PORT à 8025 ?

Offline

#5 06-09-2007 13:26:25

yml
Membre
Registered: 28-08-2007
Posts: 124

Re: SMTP : (111, 'Connection refused')

Tape sur mon front le pb est résolu. ;-)
J'ai rajouté la ligne EMAIL_PORT=25 dans mon fichier de config alwaysdata.com "settings_private.py"
Merci pour ton aide.

--yml

Offline

Board footer

Powered by FluxBB